Pagina 1 di 3 123 UltimaUltima
Risultati da 1 a 10 di 29
  1. #1
    Staff • Autore L'avatar di Pierluigi Panunzi
    Data Registrazione
    Jan 2012
    Località
    Roma, vicino a Monte Sacro
    Messaggi
    1,416
    Taggato in
    73 Post(s)

    Stellarium non mi funziona... Niente paura...

    ... ma ve lo dico subito: questo post è particolarmente pesante e ostico per chi non digerisce bene il computerese... però trovo che sia un'utile palestra di allenamento per verificare le proprie conoscenze in questo campo non proprio facile...
    pensate che i ragazzini già affrontano e risolvono questi problemi, ma magari non sanno tirare un calcio ad un pallone... ma questo è tutto un altro discorso...
    pronti? tuffiamoci con un bel salto mortale dentro il nostro programma...

    Vediamo intanto come lavora Stellarium e quali librerie utilizza: in qualunque versione sia installato, dipende totalmente dalla presenza nel PC delle librerie grafiche OpenGL (più alta la versione, meglio è), che si trovano sempre inglobate nel driver della scheda video: la scelta di utilizzare le OpenGL (così come nel caso di Celestia) è stata fatta dai creatori del programma per renderlo il più possibile multipiattaforma (PC, linux e Mac).
    Purtroppo questa scelta si scontra con il fatto che tali librerie, nel mondo di mamma MicroSoft, sono praticamente ignorate e abbandonate al loro destino dal momento che Windows utilizza la libreria DirectX e sue evoluzioni.
    Se il costruttore della scheda video prevede aggiornamenti costanti per i driver video nelle varie situazioni (da Windows XP a Vista, a Seven fino a Windows 8), allora il tutto continua al meglio. Ma già ad esempio l'Intel ha deciso di non upgradare i driver di alcune schede video ritenute "vecchie" per il neonato Windows 8: in questi casi l'utente (come è successo al sottoscritto...) viene abbandonato con a malapena la versione 1.1 (quella di base) con il che utilizzare il programma è davvero un pianto.

    Per questo motivo, in base alla piattaforma di partenza e in base alla bontà dei driver video, l'effettivo funzionamento di Stellarium sarà ottimale o catastrofico (per fortuna i casi peggiori sono in genere pochi): se qualcosa non funziona, allora bisogna subito andare a controllare il file "Last run log", per capire se ci sono eventuali errori della scheda grafica o di qualche altro componente software.
    Come trovare questo file (il "log dell'ultima esecuzione") se (apparentemente...) non riusciamo nemmeno ad eseguire il programma stesso?
    Presto detto: quando installiamo il programma, vengono creati dei file di installazione, disinstallazione, configurazione nell'apposita cartella chiamata Stellarium, tra i programmi installati sul PC e raggiungibili premendo il pulsante di START in basso a sinistra (che in Windows 8 è invece fatalmente scomparso...)
    st32-3.png
    si tratta di un file di testo che consiglio di leggere con notepad++ e non certo con notepad (originario, quello di Windows) nè tantomeno con word, a meno di non essere masochisti...

    Questo file è decisamente per addetti ai lavori e molto lungo da analizzare, ma studiandolo un po' per volta potrebbe essere anche possibile diagnosticare quale sia il problema che provoca un malfunzionamento del programma.
    Perciò, se doveste incontrare errori o malfunzionamenti, è questo il file da controllare per cercare di risolvere il problema: allegatelo in un post e così l'analizzeremo insieme!

    Come esempio di last run log (che in realtà si chiama più semplicemente "log.txt" e si trova in una cartella abbastanza nascosta, ma raggiungibilissimo cliccando il pulsantone di windows, andando tra i programmi, aprendo la cartella Stellarium e cliccando su "Last run log") adesso allego il file dal mio PC
    stellarium 1.txt
    Questo è un lungo file di log (88 righe) di una versione 0.12.0 di Stellarium in un sistema a 64 bit: in generale non differisce da quello che si riscontra con altre tipologie di PC, riga più riga meno...
    A proposito di righe, piuttosto che postarlo l'ho messo come link: scaricatelo e così potete seguire quanto dirò nel seguito...
    Ho contraddistinto ogni riga con un numero (tipo i versetti della Bibbia...) in modo tale da avere sempre un riferimento.

    Qui invece riporto i miei commenti con la riga a cui si riferiscono...

    1) data e ora dell'ultimo accesso al programma
    2) sistema operativo utilizzato
    3-5) notizie sulla compilazione del programma
    6) il mio sistema è a 64 bit: questa è la versione di stellarium caricata
    10-11) velocità e tipo di processore (il mio è un quad core)
    20) versione di stellarium
    23) il nome del file di log (quello che stiamo analizzando)
    28 e succ) importantissime e fondamentali! indicano qual è il livello di OpenGL raggiungibile dalla scheda video (segnalata nelle linee 31-32) : nel mio caso è 3.3.0, visto che è un PC abbastanza nuovo...
    33) altre predisposizioni legate all'OpenGL
    38) la lingua: già sapete che io preferisco nettamente l'inglese...
    40) il caricamento dei dati... segnalazioni di errore in queste linee indicano che non si sono letti correttamente dei dati
    41) oggetti del sistema solare caricati
    43) caricamento dei cataloghi stellari... io carico tutti e 8 i cataloghi...
    54 e succ) oggetti NGC, culture, nomi delle stelle, costellazioni, le loro immagini ed i confini
    67) l'interfaccia utente
    68 e succ) i plugin abilitati: io ho abilitati solo i 4 che sono segnalati
    76 e succ) altre routine strettamente legate al livello OpenGL: "Built successfully" appare solo se l'OpenGL lo consente, altrimente esce una sfilza di errori...
    ecc...

    ci siete ancora?
    cosa aspettate a scaricare questo prezioso file?
    Telescopio detto Monster : SkyMaster 25012 (riflettore da 10"), montatura equatoriale HEQ6 motorizzata, oculari Hyperion, ecc ...

    LA GUIDA DI STELLARIUM
    LE COSTELLAZIONI IN 3D
    LE SONDE SPAZIALI
    I VIAGGI VIRTUALI

  2. #2
    Nana Bianca L'avatar di garmau
    Data Registrazione
    May 2012
    Località
    olbia
    Messaggi
    6,256
    Taggato in
    485 Post(s)

    Re: Stellarium non mi funziona... Niente paura...

    Spero che non mi capitino mai problemi del genere, sarebbe la volta buona che il computer lo distruggo "fisicamente"...
    -MAURIZIO-
    Leggi di Murphy sul big bang: all'inizio era il nulla. Poi qualcosa ando' storto.

  3. #3
    Pianeta L'avatar di MarcoG89
    Data Registrazione
    Jan 2013
    Località
    San Giorgio Ionico (TA)
    Messaggi
    85
    Taggato in
    0 Post(s)

    Re: Stellarium non mi funziona... Niente paura...

    Ciao, tempo fa feci un aggiornamento della scheda video e da quel momento in poi, quando apro stellarium si forma una riga orizzontale sullo schermo e il programma va lentissimo. Allego il mio file lust run log.

    PS. Il mio portatile è un Toshiba Satellite p300-1ak, la scheda video è ATI Mobility Radeon HD 3470
    File Allegati File Allegati

  4. #4
    Staff • Autore L'avatar di Pierluigi Panunzi
    Data Registrazione
    Jan 2012
    Località
    Roma, vicino a Monte Sacro
    Messaggi
    1,416
    Taggato in
    73 Post(s)

    Re: Stellarium non mi funziona... Niente paura...

    Marco...
    alla riga 24 c'è scritto: OpenGL supported version: "1.1.0"
    è qui il problema... la riga orizxzontale è sintomo di una grafica non funzionante...

    la scheda grafica non è ben supportata e l'OpenGL è quello più scrauso...

    strano... Windows 7 dovrebbe aggiornare lui i driver: pensa che a me lo ha fatto su un "vecchio" portatile di 4-5 anni fa, che adesso oltre ad essere rinato (prima c'era windows XP!!) ha potenzialità grafiche notevoli... peccato solo che è pesantuccio...

    vediamo come fare...
    hai provato ad eseguire la versione "Stellarium (no OpenGL2)" ?
    magari migliora ... cosa ti dice ora il file di log?

    però mi viene in mente un'altra strada da percorrere...
    hai provato ad aggiornare il driver dal pannello di controllo- gestione dispositivi- ecc ?
    magari c'è una versione nuova (speriamo!) che Windows Update non ti fa vedere...
    tentar non nuoce!
    Telescopio detto Monster : SkyMaster 25012 (riflettore da 10"), montatura equatoriale HEQ6 motorizzata, oculari Hyperion, ecc ...

    LA GUIDA DI STELLARIUM
    LE COSTELLAZIONI IN 3D
    LE SONDE SPAZIALI
    I VIAGGI VIRTUALI

  5. #5
    Pianeta L'avatar di MarcoG89
    Data Registrazione
    Jan 2013
    Località
    San Giorgio Ionico (TA)
    Messaggi
    85
    Taggato in
    0 Post(s)

    Re: Stellarium non mi funziona... Niente paura...

    Purtroppo mi da lo stesso problema con la versione no OpenGL2 e dal pannello di controllo mi dice che il driver è aggiornato..

  6. #6
    Staff • Autore L'avatar di Pierluigi Panunzi
    Data Registrazione
    Jan 2012
    Località
    Roma, vicino a Monte Sacro
    Messaggi
    1,416
    Taggato in
    73 Post(s)

    Re: Stellarium non mi funziona... Niente paura...

    mi accorgo ora che la versione è la 0.11.4...
    puoi provare a passare alla 0.12.0, tanto... peggio di così...

    però tu hai detto

    ...tempo fa feci un aggiornamento della scheda video e da quel momento in poi...
    potresti provare a ritornare ad una versione vecchia del driver... hai visto mai...

    direi che sono tutti tentativi abbastanza disperati, ma almeno tentiamoli tutti...

    ma con la versione a 32 bit invece c'è qualche differenza?
    Telescopio detto Monster : SkyMaster 25012 (riflettore da 10"), montatura equatoriale HEQ6 motorizzata, oculari Hyperion, ecc ...

    LA GUIDA DI STELLARIUM
    LE COSTELLAZIONI IN 3D
    LE SONDE SPAZIALI
    I VIAGGI VIRTUALI

  7. #7
    Pianeta L'avatar di MarcoG89
    Data Registrazione
    Jan 2013
    Località
    San Giorgio Ionico (TA)
    Messaggi
    85
    Taggato in
    0 Post(s)

    Re: Stellarium non mi funziona... Niente paura...

    No, con la versione a 32bit è lo stesso...Però non so come tornare ad una versione vecchia dei driver..Forse cosi si risolverebbe...Provo con la 0.12.0
    Grazie mille

    EDIT: Rimane invariato anche con la 0.12
    Ultima modifica di MarcoG89; 19-02-2013 alle 22:15

  8. #8
    SuperNova L'avatar di marcom73
    Data Registrazione
    Aug 2012
    Località
    Roma città
    Messaggi
    3,530
    Taggato in
    16 Post(s)

    Re: Stellarium non mi funziona... Niente paura...

    allora intanto GRAZIE per la tua infinita pazienza !! come detto altrove, a me non funziona la versione a 64 bit... ora ho istallato e funziona la 32 bit... qualche cosiglio ber azzerare e riprovare con la 64 bit ??
    disistallo e basa o è meglio anche fare dell'altro ?? ne approfitto per pastare il file log di questa versione.. ( il mio hardware non è al top ma neanche così obsoleto.. )
    C11 - RC8 - SharpStar 65Q - AZ EQ6 GT
    Astrobin : http://www.astrobin.com/users/marmony73/

  9. #9
    Staff • Autore L'avatar di Pierluigi Panunzi
    Data Registrazione
    Jan 2012
    Località
    Roma, vicino a Monte Sacro
    Messaggi
    1,416
    Taggato in
    73 Post(s)

    Re: Stellarium non mi funziona... Niente paura...

    marcom73...
    sto analizzando il file di log...
    leggendo le prime righe si vede che hai Windows 7 (riga 2) a 32 bit (riga 6): non vedo come tu possa installare programmi a 64 bit...
    nella riga 18 si vede che stellarium è quello a 32 bit (nella cartella C:\Program Files (x86)\... )
    ottime notizie per l'OpenGL: la versione che hai è la 4.3.0...

    aspetta... resettiamo tutto... ho qualche dubbio

    devi fare così:
    1) esegui il programma a 64 bit (ma non riesco a capire come abbia fatto ad installarlo!),
    2) leggi il file di log e
    3) salvalo qui...

    ma per caso hai installato tutte e due le versioni sullo stesso PC? questo spiegherebbe qualche anomalia...
    il file di log che hai postato è quello della versione a 32 bit!!

    ma comunque il tuo sistema è a 32 bit, almeno la versione di windows è a 32 bit...


    sul mio pc ho questo:

    miopc.jpg

    cosa dice sul tuo?
    Telescopio detto Monster : SkyMaster 25012 (riflettore da 10"), montatura equatoriale HEQ6 motorizzata, oculari Hyperion, ecc ...

    LA GUIDA DI STELLARIUM
    LE COSTELLAZIONI IN 3D
    LE SONDE SPAZIALI
    I VIAGGI VIRTUALI

  10. #10
    Staff • Autore L'avatar di Pierluigi Panunzi
    Data Registrazione
    Jan 2012
    Località
    Roma, vicino a Monte Sacro
    Messaggi
    1,416
    Taggato in
    73 Post(s)

    Re: Stellarium non mi funziona... Niente paura...

    marcog89
    per trovare la versione vecchia di un driver, l'unico è cercare sul sito dell'ATI la tua scheda grafica (ATI Mobility Radeon HD 3470)... magari ci sono ancora i driver vecchi... basterebbe quello con una versione precedente a quello che hai installato...
    sennò cerca su google "ATI Mobility Radeon HD 3470" e può essere che in qualche sito trovi i driver più vecchi...

    direi che vale la pena tentare!!

    intanto vediamo di trovare questo driver vecchio... poi vediamo come riuscire ad installarlo!
    Telescopio detto Monster : SkyMaster 25012 (riflettore da 10"), montatura equatoriale HEQ6 motorizzata, oculari Hyperion, ecc ...

    LA GUIDA DI STELLARIUM
    LE COSTELLAZIONI IN 3D
    LE SONDE SPAZIALI
    I VIAGGI VIRTUALI

Discussioni Simili

  1. Un dialogo sul nulla, il niente e -forse- il... tutto.
    Di Vincenzo Zappalà nel forum Articoli
    Risposte: 74
    Ultimo Messaggio: 11-02-2013, 04:58
  2. Meade autostar suite, non funziona LPI con Windows 7
    Di alessandro71 nel forum Software Generale
    Risposte: 6
    Ultimo Messaggio: 04-02-2013, 12:41
  3. Meglio di niente!
    Di etruscastro nel forum Report osservativi
    Risposte: 6
    Ultimo Messaggio: 29-01-2013, 14:28
  4. Sono nuova... Come funziona il forum?
    Di Jojo nel forum Mi presento
    Risposte: 19
    Ultimo Messaggio: 29-06-2012, 12:38

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •